/
TCM SearchLog Table is large

TCM SearchLog Table is large





Description of Issue

The dbo.SearchLog table in the TCM database is large 



Context
  • TCM

  • Diskspace

  • SearchLog

  • Search Log

  • Performance



Cause

When Log All Searches is enabled, the search logs every incoming search query's detail such as the date/time of the search, the userID the search was done by, the # of documents returned in the search, and how long the search took. The search queries come in anytime Munis gets the document count to display, when the TCM viewer is launched from Munis, and whenever someone does a direct search within TCM itself (Full Client and new browser-based Document Search).



Resolution
  • To clear Search Logs, from TCM full client schedule the job system.log.PurgeSearchLog

  • To disable TCM search logging:

    • Open TCM full client as admin

    • Navigate to Administration > System Setup

    • Select iDoc Documents > Search Settings

    • Uncheck Log all Searches

    • Click OK



Additional Information












Related content

Cashiering Database Has Grown Due to Log Messages Table
Cashiering Database Has Grown Due to Log Messages Table
More like this
Clearing Disk Space on a TCM Server
Clearing Disk Space on a TCM Server
More like this
Purging documents from TCM is not successful
Purging documents from TCM is not successful
More like this
TCM Search Index Offline
TCM Search Index Offline
More like this
CM how to remove Elastic Search
CM how to remove Elastic Search
More like this
How to use the Document Purge Utility to purge a large volume of attachments from the CM Full Client
How to use the Document Purge Utility to purge a large volume of attachments from the CM Full Client
More like this