Installment Date Error when creating Discovery Bills



Description of Issue

When creating a new Discovery Bill through Subsequent Billing, an error can occur after updating the Installment dates, if the next available bill number has not been assigned yet. 

  • An error occurred updating the installment dates 100 [100] [System log Id:XXXXX]

  • Failed to get bill id.



Context
  • Enterprise ERP (powered by Munis)

  • Property Tax billing

  • North Carolina

  • Subsequent billing



Cause

The user is taking steps out of order.



Resolution

Development is researching into this issue.

To prevent this error from occurring, use the following steps,

  1. Navigate to Property Revenues > Property Tax Billing > South > North Carolina > Subsequent Billing and Corrections > Subsequent Billing.

  2. Click Add.

  3. Select D - Discovery from the drop down menu for Bill type.

  4. Enter in the AR Category, Tax year, Cycle and Property as needed.

  5. Click Accept, the Bill number will be generated and displayed in the Bill number field.

  6. Click Update.

  7. Click Update Installment Dates

  8. Update installment dates as needed,

  9. Click Accept.

  10. Click Accept.

  11. Proceed with Discovery bill creation process.



Additional Information

This error has no effect on the creation of the Discovery bill or updating the installment dates.