Inventory added to a work order from a kit is not costing correctly when inventory posting has not been defined in Department Settings



Description of Issue

Inventory added to work orders is incorrectly hitting the inventory revenue account



Context
  • Enterprise Asset Management

  • EAM

  • Inventory Management



Cause

Defect occurs when servicing department on work order does not have inventory post settings defined in Department Settings



Resolution

Install MUN-470161 once it's been released

Workaround options: 

  • For work orders that have already been affected:

    1. Turn off inventory posting (Make sure that no one else is using the system)

    2. Delete the inventory from the work order

    3. Return the issue from the inventory side

    4. Turn inventory posting back on

    5. Manually add the item back to the work order

  • To prevent the issue from happening in the future, in Department Settings, pull up servicing department and define the Inventory Post setting



Additional Information