ESR Request type continuously spins in Service Request Access Portal - Due to missing or incorrect Portal Service URL

Description of Issue

ESR Request type continuously spins in Service Request Access Portal 

Context
  • Tyler 311
  • Enterprise Service Requests 
  • ESR
  • Tyler Deploy
  • Service Request Access Portal 
  • SRA Portal 
Cause

Portal service URL is incorrect or missing in Service Request Access Admin Portal

Resolution
  1. Locate the Portal Service URL
    1. Open Tyler Deploy
    2. From the left Menu, select Product Configurations > Tyler 311
    3. Select the affected environment from the dropdown
    4. Copy the Portal Service URL
  2. Navigate to Portal Administration 
  3. Click Service Request Portal Administration tab on the right side of the page
  4. Paste the Portal Service URL in the Remote Service URL field and append /vX to the end of the URL.
    1. Example https://FQDN/prod/Tyler311/portalservice/v4
    2. Chart of version compatibility that will help to guide you on what version needs to be in the service URL with which version of the ESR back office

      Back Office VersionPortal Service Version
      2019.1.xv2
      2019.2.xv3
      2019.3.xv3
      2019.4.xv3
      2020.1.0-2020.1.5v3
      2020.1.6+v4
      2020.2.xv4
      2020.3.xv4
      2020.4.xv4
      2021.1.xv4
      2021.2.xv4
      2021.3.xv4
      2021.4.xv4

      2021.1.13+

      2021.3.4+

      2021.4.1+

      v5
      2021.5.x +v5
      2021.11.x +v6
      2021.12.x +v7
  5. Confirm URL is now loading properly