Clearing Customer Cart in TPAR



Description of Issue
  • A customer will be using the Parks & Rec Portal to try and register for something, and they will run into a snag and call their Parks office. When someone tries to help them register from the admin side, they are unable to assist because the registration is locked into the customers cart. Is there a way to clear out their cart and start over?



Context
  • TPAR

  • Parks & Rec

  • Tyler Parks and Recreation



Cause

Depending on the type of transaction, you can access registrations that begin in the Portal, from the admin side.



Resolution

Classes (Option 1)

  • Navigate to Parks & Rec > Class Registrations > Pending.

  • Find and select the unfinished registration and click Delete.

  • Navigate to Parks & Rec > Class Registrations > Create.

  • Register the contact for the class as you normally would.

Classes (Option 2)

  • Navigate to Parks & Rec > Class Registrations > Create.

  • Enter the Contacts name as the Payer.

  • This should prompt the message This contact has already started a registration. Click here to view it, add/remove classes, or check out. 

  • Click the link to continue the transaction from where the citizen left off.

Memberships

  • Navigate to Parks & Rec > Memberships > Join.

  • Enter the Contacts name as the Payer.

  • This should prompt the message This contact has already started a registration. Click here to view it, add/remove classes, or check out. 

  • Click the link to continue the transaction from where the citizen left off.



Additional Information

Unfortunately, Rentals are the only portal transactions that are difficult to clear or continue from administrative side. Until a fix for this is implemented, we recommend the following options to mitigate any issues.

  • Encourage citizens to empty their cart before calling into your office. Or walk them through doing so while they are on the phone.

  • Enable Require Portal Approval in the Rental Item's Settings. Rentals can then be booked, and are invoiced and paid later upon approval.

An unfinished rental registration should not hold a time aside in the calendar, so the same registration should be possible to complete from the administrative side. Contact TPAR Support for any assistance.