How to create a ReadyForms Printer



Description of Issue

A new printer is needed to be set up as a definition to be used with Ready Forms



Context
  • Munis

  • ReadyForms

  • System Administration

  • Printer Definitions

  • ThinPrint

  • Server

  • Shared

  • App server

  • Print server

  • Add Ready Forms Printer

  • Enterprise Forms

  • Physical Printer

  • New printer



Cause

A definition needs to be set up to point to the networked printer in order to use it with ReadyForms.



Resolution

Saas Hosted, please create a case with TSM SaaS support.

On Premise:

  1. The first step is to install the printer. We recommend to install on the Enterprise ERP APP Server.  

    1. Printer should be locally installed in the Munis App server via TCP/IP and using one of the 3 specific drivers: Universal PCL5, Universal PCL6 or Generic Text Only. Most sites have Forms with TCM server.

  2. Login to Enterprise ERP (Munis)

  3. Click on the Tyler Menu > System Administration > Printer/Device Administration > Printer Definitions

  4. Click Add on the top banner

  5. Give it a Printer ID and Printer Name

    1. If using a printer installed on the EERP App Server, select Server as the Printer type

    2. If using a printer installed on a Print server, select Shared as the Printer type 

    3. For the Printer Name, use one of the following based on the type chosen above:

      1. If Printer type is Server, click the ellipses and select the printer name 

      2. If Printer type is Shared, type the server and printer name in the following format: \\[Print Server Name]\[Printer Name]

  6. Click the checkboxes for PDF Enabled and all the options under PCL printing

    1. If Printer type is Server, select Native under the Mode dropdown menu for PDF Printing

    2. If Printer type is Shared, this Mode menu option will not be selectable, skip this step

  7. Send a generic test page from any output screen to the new printer



Additional Information

Tyler Hosted SaaS clients will need to request this be configured by Tyler Systems Management SaaS Support. The printer needs to be fully networked. Support staff will require the printer's inside IP address. SaaS support will then request a NAT (Network Address Translation) address be created for any relevant Tyler VPN Appliance integrated into the client network. The printers share name noted in step 5 of the resolution step will follow Tyler hosting standard naming conventions. 

Changes to the printers private IP address will result in loss of connection to the printer from Tyler data centers. It is advised all changes to Tyler Hosted Printer IP addresses be done in coordination with a SaaS Support technician to avoid interruption of service. 

For On Premise Hosted clients, if the Printer type is set to Shared, Tyler Munis Support does not have permission to access and work on a non-Tyler server directly.

How to change the printer for a ReadyForms delivery definition