Server Resources Spiking After Daylight Savings Changeover



Description of Issue
  • Server memory and/or CPU spiking after daylight saving time change

  • All of the Centrals programs are inaccessible.  Server Error in Application after daylight saving time change.

  • Runtime Error for multiple modules after daylight saving time change



Context
  • Server

  • Resources spiking

  • Daylight savings

  • Time change

  • Munis unresponsive

  • Munis Down



Cause

Genero virtual machine processes such as sptmcsvc and the spScheduled*TaskService became unresponsive during the Fall transition from daylight saving time to standard time

Ex:

E:\muntest\fjs\fglgws\bin\fglrun.exe sptmcsvc

E:\muntestfjs.fglgws\bin\fglrun.exe spScheduledEmailTask



Resolution

SaaS Clients: Please contact Tyler Systems Management Support or log a case via the Online Support Client Portal.

OnPrem Clients:

  1. Open Task Manager on the Application server

  2. Expand the tab Command line to see the full path

    1. If you do not see this tab, right click on Name and check off Command line

  3. Identify the problem processes: sptmcsvc and/or spScheduled*Task 

    1. Right click on the process name and click End Task

    2. Please note: This task exists for each individual environment, and likely needs to be ended for all environments.

  4. This can also be resolved by rebooting the server

  5. This also could have caused the dbo.SystemLogs table in the Munis databases to balloon as the service got stuck and was using resources on the server and writing to these logs. Please contact TSM Support for assistance truncating these logs. 



Additional Information

Development is working on a MUN to address this.