Munis - What are PopUps and SmartTips





Description of Issue

Client notices new on-screen guidance and tips. What are these?



Context
  • Munis

  • On-screen guidance

  • Tyler U



Cause

Client notices new on-screen guidance and tips. First-time seeing them and looking for information on why they display.



Resolution

Users of Munis Version 2018.x and higher will soon experience new and informative user guidance in the 1099 Manager, W-2 process, ACA 1094/1095 file submission process, and other selected areas of Munis functionality. This end-user guidance is in the form of PopUps and SmartTips that have been strategically deployed to help educate users at time-of-use.

  • Is this a Munis code change? No. There is no interaction with your server environment or code. Rather, these are easy-to-deploy enhancements to the Tyler U system.

  • A SmartTip provides field-level information. The user can either mouse-hover over a field or click on a small icon and be presented with a simple to understand explanation, definition, or even an image.

  • PopUps appear in the middle of a program screen and provide important information or links to documentation to the user; usually prior to beginning a process or function. 

  • If the introduction of a PopUp or SmartTip is tied to a new feature in a new version, they will only appear in the new version (or higher).

    • For example, if a SmartTip is made available in version 2021.2, it will only display in version 2021.2 or higher. In the case of the AP Manager, a form format option is relevant to versions 2018.x, 2019.x, 2020.x, etc., so PopUps and SmartTips are in all those versions.

  • Support and the Tyler U Instructional Design team set the display frequency based on the needs of clients and feedback from the Munis Support Teams. SmartTips will appear any time one interacts with the field or icon. PopUps will generally appear every time the program is used. That said, they will have an opt-out control at the bottom (e.g., Don’t show this again).

  • To submit a suggestion for a PopUp or SmartTip, please submit it through the Online Support Incidents portal. In order to evaluate your suggestion, please provide as much detail as possible, including your ideas on the wording of the guidance provided to the end-user.



Additional Information