Unable to Export From Munis



Description of Issue

Export functionality within Munis is not working

Error will commonly present itself as:

The website cannot display the page HTTP 500



Context
  • Munis

  • Reports

  • Export

  • PDF

  • Word

  • Excel

  • GAS



Cause

This issue is most commonly caused by a hung GAS connection in the affected Munis environment



Resolution
  1. Sign onto the Munis Application Server as Tylerservice (or equivalent)

  2. Open the Internet Information Services program (IIS)

  3. Browse out to the MunisHosting<env> website

  4. Click on Configure Site

  5. Next to GAS Connection, click on Test Connection to verify the GAS connectivity

  6.  If the connection fails you will want to restart GAS for that environment

    1. On the Munis Application Server open an administrative command prompt

    2. Run this command: restartgascmd *prod*

      1. *prod* can also be *live* based on your application pool naming convention. Non production environments would be *test*, etc.

  7.  Test exporting in Munis to ensure it is working again

  8. Contact Tyler Systems Management if you need further assistance






Additional Information

If all users are unable to export to PDF in a system then a GAS restart may be required. Please use this article Unable to Export From Munis