No Records Found with Deposit Amount to Apply





Description of Issue

Apply Deposits Error

Customer with Deposit unable to apply



Context
  • Munis

  • General Billing

  • General Billing Deposits

  • Apply Deposits



Cause

In this scenario a user might be met with an error of No records found with a deposit amount to apply in the Apply Deposits module. This error persists even when the Customer has a deposit amount in their account and a due amount on a bill. This is due to a Deposit Setting restriction that is set within the Accounts Receivable Charge Codes program for Deposit charge codes. 



Resolution

The issue is related to the Deposit Settings option in the Munis ribbon when selecting a General Billing Deposit charge code. Please review any and all Deposit Charge Codes to see if there are any restrictions set within the module. 

  1. Navigate to General Revenues>Accounts Receivable>Setup>Accounts Receivable Charge Codes

  2. Click Deposit Settings

  3. In this Deposit Settings module, there are two restriction options which can directly effect what records the Apply Deposits program consider eligible. 

    1. AR Code - Restrict the application of deposits with this Charge Code to Invoices with the following AR Code

    2. Charge Codes - Restrict the application of deposits with this Charge Code to Invoice lines with the following Charge Code(s)

  4. Upon adding, removing or updating any Deposit Setting restrictions the user can return to Apply Deposits and expected records should now select. 

If the issue persists or any further errors display, please submit a case to Munis Support.



Additional Information

For General Billing charge codes designated as deposit charge codes, the Deposit Settings screen defines how deposits assigned to this charge code are applied.

Click Update to assign the AR Code and Charge Code restrictions:

  • Select the Restrict the Application of Deposits with this Charge Code to Invoices with the Following AR Code check box and then specify the code.

  • Select the Restrict the Application of Deposits with the Charge Code to Invoice Lines with the Following Codes Charge Codes check box and then specify the codes.

The AR Code option restricts the application of General Billing deposits with this charge code to invoices with the AR code specified. The Charge Codes option customizes this deposit charge code further by limiting its application to invoice lines with charge codes that are added to the list. If you have also opted to restrict by AR code, then only charge codes with an AR code that matches the one you selected can be added to the list. If any of the charge codes on the list are subject to sales tax, then the corresponding sales tax charge code is automatically included in the list.