Munis Upgrade Options





Description of Issue

We are looking to request an upgrade to our Munis, what options are available to us?



Context
  • Munis

  • On Premise

  • Software As A Service (SaaS)



Cause

Need to evaluate options to upgrade Munis



Resolution

All Munis clients can submit Upgrade Requests through Tyler Systems Management via the Client Portal



Additional Information

For Clients that are already Live on Munis, there are two types of common projects:

In-Place Upgrade - SaaS clients or On Premise clients with supported platforms

  • Current Test environment upgraded first (1-3 day engagement depending on number of products, environment complexities, etc.)

  • Testing is completed in the existing Test environment

  • Separate engagement is scheduled for Live/Prod environment, as well as Train and any supported Custom Environment. (typically 1 day of down-time for the Live/Prod upgrade, then add one day per additional environment as applicable)

  • May require an additional server to meet the needs of newer technology required for the newer product versions, such as Tyler Identity (On Premise Clients Only)

Server Migration  - On Premise Clients Only

  • Server Migrations are required if the Operating System of the current server(s) is not supported

  • Tyler will provide recommended server footprint and resource specifications for all new servers

  • Client provisions the new servers

  • Client completes pre-deployment tasks per the instructions/guidelines in the Specifications document

  • New Munis version is installed on ALL environments on the new servers with a copy of your current data for parallel testing

  • Testing is completed in the Prod environment on the new target servers

  • Separate engagement is scheduled for the “Cut to Live” engagement when Client has completed testing and is ready to move to the new version/servers (typically a 1.5 day of downtime for this engagement)