How to escalate a support case





Description of Issue

We need to escalate a support case to increase visibility, how do we escalate a support case?



Context
  • Tylertech.com

  • Client Support

  • Online Support Incidents



Cause

User needs to escalate a support case.



Resolution
  1. Navigate to www.tylertech.com.

  2. Select Login in the upper-right corner of the webpage.

  3. Enter your account username and password.

  4. Select Client Support in the upper-right corner of the webpage.

  5. Select your Tyler product.

  6. On the support page, select Get Online Support.

  7. Select My Cases in the upper-right corner of the webpage.

  8. Select the ID of the specific case.

  9. Select Escalate to escalate a support case.



Additional Information

Please review our Technical Support Overview for Munis for the proper procedure to escalate a case.

Please review the Master Article - Client Support for all additional topics.