/
Longevity not using new salary rate

Longevity not using new salary rate





Description of Issue

Longevity calc code 71 calculating on old Job/Salary rates after mass contract increase. 



Context
  • Munis version 2018.1 and higher

  • Payroll

  • Employee Job/Salary

  • Longevity and Experience Report



Cause

Longevity pay Effective date was not updated after performing Mass contract increase, causing Longevity pay to use old pay rates.



Resolution

Update the effective date for the longevity pay in Job/Salary to use new salary amount.

  1. Navigate to Job/Salary: Payroll>Employee Maintenance>Employee Job/Salary

  2. Search for active employees and the longevity pay code

  3. Select Global update

  4. Click Define

  5. Enter Effective date of new Base Pay record

  6. Accept, and Execute.

Longevity pay will now look to new base pay record with matching effective date



Additional Information












Related content

Longevity pay is recalculating in Employee Job/Salary
Longevity pay is recalculating in Employee Job/Salary
More like this
Longevity Pay not calculating correctly
Longevity Pay not calculating correctly
More like this
Rate for Longevity Pay is Incorrect After Running Longevity and Experience Report
Rate for Longevity Pay is Incorrect After Running Longevity and Experience Report
More like this
Will longevity pays recalculate automatically
Will longevity pays recalculate automatically
More like this
Longevity Date default in Employee Job Salary
Longevity Date default in Employee Job Salary
More like this
Recurring Pay incorrect for Longevity after recalc
Recurring Pay incorrect for Longevity after recalc
More like this