Recurring Pay incorrect for Longevity after recalc

Description of Issue

After updating the Longevity Date for a Longevity Pay Code, and clicking Recalc in Employee Job/Salary, the hourly rate is correct but the Recurring Pay is wrong. 

Context
  • Enterprise ERP Payroll

  • Employee Job/Salary

  • Pay Master

  • Longevity Tables

Cause

Checkbox for Allow Recalc of Pays is not checked on Longevity Table.

Resolution
  1. Navigate to Payroll>Payroll Setup>Pay Master.

  2. Click Search and enter Longevity Pay Code.

  3. Click Accept.

  4. Click Longevity.

  5. Click Update.

  6. Check box for Allow Recalc of Pays.

  7. Click Accept.

  8. Navigate to Payroll>Employee Maintenance>Employee Job/Salary.

  9. Search for Employee and Pay Code with applicable Search Period.

  10. Click Accept.

  11. Click Recalc.

    1. If a new Longevity Date needs to be entered, check box for Change Longevity Pay Dates and enter new date.

  12. Click Accept.

Additional Information