Executime Inactive Employees showing in time approval

Description of Issue

Supervisors are able to see the terminated employees under supervisor actions > time approvals > employee. (drop down)

Context
  • Executime
  • Time Approvals
  • Master File Management
  • Status Codes
Cause

An Additional Status Code was added for Inactive, instead of the Terminated code be renamed to I - Inactive. 

Resolution
  1. Log into ExecuTime and click System Admin, then Master File Management, then click the Status Codes tab.
  2. Click the Edit pencil icon next to the manually added I - Inactive code. 
  3. Edit the Name from I to I2. Click Save
  4. Click the Edit pencil icon next to the Terminated code.
  5. Update the Name from Terminated to I. Update the Description from Terminated to Inactive. Click Save
  6. Run the Full Integration for the Employee Import again or wait for the Entity Service to run at it's scheduled time, then confirm the employee(s) are now showing Inactive in ExecuTime. 
Additional Information