Employees show Inactive in Munis but still Active in ExecuTime

Description of Issue

Employees that are set to Inactive in Munis are still showing Active in ExecuTime, even after running the full integration in ExecuTime. 

Context
  • Munis
  • Employee Master
  • ExecuTIme
  • Master File Management
  • Status Codes
Cause

During implementation the Status Code for Terminated was not changed to I for Inactive, instead an Inactive Status code was added in error. 

Resolution
  1. Log into ExecuTime and click System Admin, then Master File Management, then click the Status Codes tab.
  2. Click the Edit pencil icon next to the manually added I - Inactive code. 
  3. Edit the Name from I to I2. Click Save. 
  4. Click the Edit pencil icon next to the Terminated code.
  5. Update the Name from Terminated to I. Update the Description from Terminated to Inactive. Click Save. 
  6. Run the Full Integration for the Employee Update again or wait for the Entity Service to run at it's scheduled time, then confirm the employee(s) are now showing Inactive in ExecuTime. 
Additional Information

Leave the I2 Status Code as it will not impact anything going forward.Â