Troubleshooting a Signature Key

Description of Issue

Signature key is not working as expected or the light is red when plugged into the Secure Print Module.

Checks are printing VOID.

Context
  • Tyler Forms
  • Signature Keys
  • Secure Signature System
  • Secure Print Module
  • Check Printing
Cause

Signature key is not working as expected or the light is red when plugged into the Secure Print Module.

Resolution

Best two steps for resolving Signature Key issues:

  1. Take canned air to the key and all the ports involved (usb signature key, port that the key plugs into, and port on the printer that the module cord plugs into).
  2. Unplug everything in order and plug back in everything in the opposite order: 
    1. Unplug the key from the module>Unplug the module from the printer and the power to the module>Unplug the power cord from the printer and let it sit for 2 to 3 minutes.
  3. Plug the power cord back into the printer and give the printer at least a few minutes to fully load and initialize and show in "ready" status.
  4. After the printer is fully powered back up, plug the power cord back into the signature module and give it about 15 seconds then plug the cord from the module that goes to the printer back into the printer. Once plugged into the printer give it about 30 seconds before going to the signature key.
  5. Plug the signature key into the module and make sure it is fully seeded into the module. Any of the applicable LED lights on the key/module should then either blink green or go solid green once ready.

If showing green, it is then ok to print your Checks to it.

If it is not green that means there is a problem. Please create a support case to help troubleshoot further, or to initiate a Request for Service to see about options for processing without the module.

The most important thing to remember when unplugging everything and plugging it back in is to make sure to give plenty of time between each step.

Additional Information

Secure Signature System and USB Key Hardware Update

We have recently been informed by the third-party hardware manufacturer used for secure signature systems and USB keys with forms printing, that effective immediately, this hardware will no longer be manufactured. Like many other electronic devices, parts have become increasingly difficult to obtain in the last few years and there are no plans to manufacture these parts in the future, making them permanently unavailable.

This was one layer in many layers of security that Tyler provided for check printing, and as such, we are confident that even without the signature system, check printing in the ERP software provides ample security.

What does this mean for our clients?

  • New ERP implementations will not be installed with the signature system that was included on their contract, nor will they be billed for it. This hardware is only billed when shipped, and since it will not be shipped, it will never be billed.
  • The one-year warranty from date of purchase for currently used systems will be honored. It is important to note that the signature system and USB keys are expected to be functional for your use for many years given the strong history of reliability.
  • For Enterprise Forms (ReadyForms) clients using standard checks, you can opt out of using the signature system in the Enterprise Forms (ReadyForms) application at any time should you experience an issue.
  • For DocOrigin clients or Enterprise Forms (ReadyForms) clients using custom check designs, if you experience any issues with your signature system or keys, please reach out to Forms support as you normally would, and we will work with you to resolve any issues that you experience.
  • If you have questions regarding this announcement, please send them to design@tylertech.com.

We apologize for any inconvenience this may cause, and we thank you for your kind understanding.