Payment Entry Batches Stuck In Review

Description of Issue

Batches stuck in review

User approved batches but are stuck in review

Context
  • Munis
  • Accounts Receivable
  • Payment Entry
  • Payments Journal
  • User Attributes
  • Roles
  • Workflow
Cause

This scenario may present itself when a site is utilizing any Payment Workflow Business Rule configurations and Users Roles may have Release Batch Status set to In Review within the Accounts Receivable Permissions. When PEA Workflow is enabled within Business Rules, sites will not want users to have this permission set to In Review. This may cause users who are Approvers to set Payment Batches as In Review even though they have just approved them within the PEA Workflow process. 

Resolution

Users who are PEA Workflow Approvers will need to set the Release Batch Status to Released to avoid getting batches stuck as In Review. For any batches stuck as In Review from when the case was submitted, once the site updates the Release Batch Status to Released that user should be able to go Resume the same batch and subsequently re-output release it. 

If there continues to be issues with the batch any further, please submit a case with Munis support. 

Additional Information

If a site wishes to use the In Review option within Accounts Receivable Permissions, this can be done where a set of users have the In Review option set and then another set of users have Released option set. This creates a workflow like process without using Workflow Business Rules.Â