/
Reboot TouchTime III Device

Reboot TouchTime III Device

Description of Issue

Device screen is stuck at windows home screen showing Press Ctrl+Alt+Delete or use the Windows Security button to unlock.

Context
  • ExecuTime
  • ET
  • TouchTime III
  • Timeclock
Cause

Device needs to be rebooted

Resolution
  1. At timeclock, unplug power cable from the device
  2. Hold down the white button on the back of the device
  3. Once device has rebooted, Plug power cable back into device
Additional Information






Related content

Reset TouchTime VII to Re-Register
Reset TouchTime VII to Re-Register
More like this
TouchTime 3 Proximity Reader Configuration
TouchTime 3 Proximity Reader Configuration
More like this
TouchTime III Screen is Black
TouchTime III Screen is Black
More like this
Critical Error on TouchTime in Device Management
Critical Error on TouchTime in Device Management
More like this
How to move a TouchTime clock from Device Management to Timeclock Management
How to move a TouchTime clock from Device Management to Timeclock Management
More like this
How to power cycle TouchTime clocks
How to power cycle TouchTime clocks
More like this