FourJs License Expired
Description of Issue
We are seeing errors within Munis telling us to reach out to our Munis Sales Representative regarding licensing
Please contact your sales office regarding licensing
Error above displays on the first page of Munis report output. The report is printed on subsequent pages. The error does not result in work stoppage.Â
Alternative error: The date-limited license has expired. Contact vendor. - Munis(sprunpgm) Program Stopped at spsetwin.4gl
Context
- Munis
- FourJ's
- License
- Maintenance Key
- MIU
- Tyler Deploy
Cause
The FourJ's License and Maintenance Key expires at the end of the year on 12/31 and needs to be renewed yearly for Munis Reporting to function correctly.
Resolution
- Clients have until 3/31 of the following year to install the renewed license before errors will present
- This can be renewed via Tyler Deploy
- Tyler Deploy will update the License and Maintenance Key for an environment when a Munis ERP update is applied to that environment after 1/15
- If you have not run any updates to your Munis ERP environment since this date, please do so and the License and Maintenance Key will be updated in the environment
- How to Run or Schedule an Update in Tyler Deploy for a Product
- Alternatively, there is a non-invasive task that you can run from Tyler Deploy. To do this you will need to have access to Tyler Deploy for your site and follow the steps below:
- Sign into Tyler Deploy and connect to applicable tenant
- Navigate to Munis ERP Product Deployment page for desired environment
- Click the Tasks tab next to Product Release
- In the dropdown, select Update Genero & Report Engine LicenseÂ
- Click Run and wait for completion
- Once you have completed the Tyler Deploy methods, please have a user test to make sure they are no longer receiving the error. End users may need to clear cache and log out for renewal updates to take effect.Â
- If you have any issues or need further assistance, please contact Tyler Systems Management Support or log a case via the Online Support Client Portal
Additional Information
- Please note: The MIU Application is retired and should no longer be utilized to update the FourJ's maintenance key as it will update to an already expired key. Contact TSM Support for assistance if Tyler Deploy is not an option.
- 4/1/2024 - This is a trending issue and may even be occurring in some cases where the 4J's license looks valid. Additional information here:
- This message is printed on the first page of the report, but subsequent pages of the report should output as expected.Â