General Billing Recurring Invoices are not being selected

Description of Issue

The Recurring Invoices program is not generating all invoices

Context
  • Munis
  • General Billing
  • Recurring Invoices
Cause

One of more data conditions on the Recurring Invoice Template is preventing the invoices from being selected.

Resolution

Confirm the Generate Criteria Screen has the correct Month, Week, and AR Code to match the Recurrence Pattern

Is the Contract Amount populated? 

  • When the Billed amount matches or exceeds the contract amount, the recurring invoice will not be selected. 
  • To remedy, update the recurring invoice to change or remove the contract amount.

Is the Start Date populated with a future date?

  • When the Start Date future dated ahead of the Invoice Date in the Generate Criteria Screen, the bill will be skipped.
  • To remedy, update the Start Date on the recurring invoice.

Has the End Date passed? 

  • When the Invoice Date used in the Generate Criteria Screen selection is after the recurring invoice end date, the bill will be skipped.
  • To remedy, update the End Date on the recurring invoice

Is the Last Date Invoiced set to a date where the recurrence pattern is not valid? 

  • If the recurrence pattern is set to occur monthly and the last date invoiced is within the same month you selected in Generate Criteria Screen, the bill will be skipped.
  • IF the recurrence patter is set to occur yearly and the last date invoiced is within the same year selected in the Generate Criteria Screen, the bill will be skipped.
  • To remedy, update or clear the Last Invoiced Date from the recurring invoice


Additional Information