Step not within min/max for Job Class.

Description of Issue

I am receiving an error updating an Employee Job/Salary record stating Step not within min/max range for Job Class.

Context
  • Munis
  • Employee Job/Salary
  • Job Class Master
Cause

Job Class did not have a min/max step defined.

Resolution
  1. Access Job Class Master: Payroll > Payroll Setup > Job Class Master.
  2. Search on the applicable Job Class.
  3. Click on the Salary Data tab.
  4. Click Update.
  5. Next to Min Step click the ellipsis (...)
  6. Select minimum step.
  7. Click Accept.
  8. Next to Max Step click the ellipsis (...)
  9. Select maximum step.
  10. Click Accept.
  11. Click Accept in Job Class Master.
Additional Information