Manager Self Service is not available in ESS

Description of Issue

Supervisors were not seeing the option for Manager Self Service when they were logged into Employee Self Service

Context
  • Munis
  • Employee Self Service
  • Manager Self Service
  • Personnel Settings
  • Payroll Control Settings
Cause

The Personnel Settings program was set to Use Position Number in Supervisor Field and the Payroll Control Settings program had each of the Supervisor category options set to something other than No. The Personnel Setting instructs the system to look at the Position Control record for the supervisor's position (instead of employee number). The Payroll Control Settings were directing the system to determine the supervisor by something other than employee number (Position and Job Class, by Position (Primary only) or by Position). These combination of settings prevented the system from identifying an employee number to use for the supervisors. Due to that setup, Manager Self Service did not have a clear indication of what the supervisor's employee number was, this prevented the system from resolving how to link employees and supervisors.

Resolution
  1. Go to the Personnel Settings Program (Human Capital Management>Personnel Setup>Personnel Settings)
  2. Select the Position Control tab
  3. If the Use Position Number in Supervisor Field field is selected, then set the Payroll Control Settings as follows:
    1. Go to the Payroll Control Settings program (Human Capital Management>Payroll>Payroll Setup>Payroll Control Settings)
    2. Search/Filter by typing *Supervisor* in the first empty field, then select Category from the drop-down list and press Go
    3. In the five results that are returned, select the item labeled Supervisor by Position. This setting determines how the employee's supervisors are resolved
      1. The options are: N- Determine Supervisor by Employee Number, P- Determine Supervisor by Position (Primary Only), or Y - Determine Supervisor by Position
    4. Click Update.
    5. Set Supervisor by Position to N, so Munis will resolve the lookup of the supervisor by the Supervisor number in the Supervisor field in Employee Master.
    6. Click Accept.
  4. If the Use Position Number in Supervisor Field is not selected, then set Payroll Control Settings as follows:
    1. Go to the Payroll Control Settings program (Human Capital Management>Payroll>Payroll Setup>Payroll Control Settings)
    2. Search/Filter by typing *Supervisor* in the first empty field, then select Category from the drop-down list and press Go
    3. In the five results that are returned, select the item labeled Supervisor by Position. This setting determines how the employee's supervisors are resolved
      1. The options are: N- Determine Supervisor by Employee Number, P- Determine Supervisor by Position (Primary Only), or Y - Determine Supervisor by Position
    4. Click Update.
    5. Set Supervisor by Position to P or Y, so Munis will resolve the lookup of the supervisor through the employee number listed in the Supervisor field in Position Control.
    6. Click Accept.
Additional Information

Refer to this article for other steps that may need to be reviewed too: Manager Self Service is not appearing for a supervisor (ESS)