InCode payroll shows connectivity error in ET

Description of Issue

InCode payroll shows connectivity error in ET

Context
  • ExecuTime
  • ET
  • InCode
Cause

Incorrect Class name for Move To Payroll function field configured

Resolution

If ET is OnPrem self hosted then follow the below steps. If Tyler hosted then open a support ticket.

  1. Confirm the issue is a DB issue by checking the ET logs. You should see an error related to the class type such as Cannot Load Desired Class Net.executime.dataexport.tylerintegration.TylerPayrollExportDaily
  2. Go to System Admin > Admin and make note of what is in the field Class name for Move To Payroll function field. It should match what you found in the logs.
  3. Enter the correct class name in ET in the field identified in step 2. (NOTE: this is case sensitive) If unsure of correct class name please contact ET support.
  4. Hit the Save button at the bottom of the page.
  5. Verify problem is resolved using the Payroll Functions>Time Balancing > Test Connection button.
Additional Information

There are 2 locations in ET app to test payroll connectivity.

  • System Configuration>Tyler Connectivity>Test Tyler Web Connectivity button. This just tests basic network connectivity to the InCode server.
  • Payroll Functions>Time Balancing > Test Connection button. This one verifies connection to the DB. If this one fails follow the resolution steps below.