FourJs License Expired

Description of Issue

We are seeing errors within Munis telling us to reach out to our Munis Sales Representative regarding licensing

Please contact your sales office regarding licensing

Error above displays on the first page of Munis report output. The report is printed on subsequent pages. The error does not result in work stoppage. 

Context
  • Munis
  • FourJ's
  • License
  • Maintenance Key
  • MIU
  • Tyler Deploy
Cause

The FourJ's License and Maintenance Key need to be renewed yearly for Munis Reporting to function correctly.

Resolution
  • The FourJ's License and Maintenance Key expires at the end of the year on 12/31 and needs to be renewed. There is a 3-month grace period the following year which allows a client to have until 3/31 to get the license renewed. The MIU and Tyler Deploy Products are designed to renew this for clients. Please see below on the process for each:

    • Tyler Deploy application will also update the License and Maintenance Key for an environment if an update is applied to that environment between 1/15 and 2/28. If you have not run any updates to your environment during this time, please do so and the license and maintenance key will be updated in the environment. Alternatively, if you do not wish to install any updates into an environment, there is a task that you can run within Tyler Deploy to update this as well. To do this you will need to have access to Tyler Deploy for your site and follow the steps below:
      1. Sign into Tyler Deploy
      2. Select your customer
      3. Click on the menu icon on the top left
      4. Click on Product Deployments> Munis ERP
      5. Select the environment having the issue
      6. Click on the Tasks tab next to Product Release
      7. Select Update Genero & Report Engine License in the dropdown
      8. Click Run and wait for completion
    • The MIU application on the server, when opened and an environment tile is clicked on between 1/15 and 2/28, is designed to renew the FourJ's License and Maintenance Key automatically for the environment. If this was not done between 1/15 and 2/28 please follow the steps below:

      1. Sign onto your Munis Application server as Tylerservice (or equivalent)
      2. Open the MIU application
      3. Click the environment tile and let it load until it reaches the next screen. Then press Return.
      4. Please do this for all environment tiles to ensure that all environments have the license renewed.


  • Once you have completed the MIU or Tyler Deploy methods, please have a user test to make sure they are no longer receiving the error. End users may need to clear cache and log out for renewal updates to take effect. 


  • If you have any issues or need further assistance, please log a support case with Tyler Systems Management

Additional Information