ThinPrint Connection Troubleshooting

Description of Issue

ThinPrint service on the client server is not showing a connection back to the Tyler ThinPrint server. 

Context
  • EERP Munis
  • ThinPrint Configuration
  • Forms Printing 
  • Print Server
Cause

Incorrect client installation, service needs a restart or client server port issue. 

Resolution
  1. Verify there are no additional spaces before or after the hostname in the ThinPrint Client and that the Client ID and Auth Key were entered correctly
  2. Restart the ThinPrint service
    1. On the local print server, launch Services
    2. Locate the TP Client Windows service and click Restart 
  3. Verify the local printer server where ThinPrint is installed can connect back to the Tyler print server
    1. On the local print server, launch PowerShell
    2. Type in the following commands for eastern region
      1. Test-NetConnection -ComputerName erpthinprint.tylerhost.net -Port 4000
      2. Test-NetConnection -ComputerName erpthinprint.tylerhost.net -Port 4001
      3. Test-NetConnection -ComputerName erpthinprint02.tylerhost.net -Port 4000
      4. Test-NetConnection -ComputerName erpthinprint02.tylerhost.net -Port 4001
    3. Type in the following commands for western region
      1. Test-NetConnection -ComputerName erpthinprint03.tylerhost.net -Port 4000 
      2. Test-NetConnection -ComputerName erpthinprint03.tylerhost.net -Port 4001
    4. If True:  connection is successful
    5. If False:  connection failed.  Reach out to Tyler Support for further assistance.
  4. Contact Tyler Systems Management Support or log a case via the Online Support Client Portal if you need further assistance.

Note:  Ports 4000 and 4001 must be open for bidirectional traffic on the print server for successful communication with Tyler's ThinPrint server.

Additional Information

Additional resources:  Master Article - ThinPrint