Resetting filter on Match screen by Transaction Type Journal show more unmatched journals than expected - Reset functionality also resets the bank account





Description of Issue
  • User selects a bank account on match screen and clicks Filter in ribbon

  • User selects Journal from Transaction Type dropdown under Munis Items and clicks Filter

  • Unmatched journals display as expected

  • User clicks Filter in ribbon again and then Reset (without noticing Bank Account dropdown now shows All)

  • User selects Journal from Transaction Type dropdown under Munis Items and clicks Filter before selecting bank account

  • All Unmatched journals are now pulling in but user was expecting only Unmatched journals for specific bank account



Context
  • Bank Reconciliation Manager

  • Match screen

  • Filtering



Cause

Reset functionality also resets the bank account



Resolution

To display unmatched journals as expected after resetting filter: 

  • After clicking Reset, select bank account from Bank Account dropdown before defining the Transaction Type

  • Select Journal from Transaction Type dropdown under Munis Items and click Filter

Unmatched journals specific to bank account will now display



Additional Information

By clicking reset, the bank account defaults to All and will show any unmatched journal for any bank account