Create ODBC connection for OnPrem clients

Description of Issue

Need ODBC connection to Enterprise ERP database created on new workstation

Context
  • Crystal reports

  • ODBC

  • Enterprise ERP any version

  • Self-hosted, OnPrem clients

Cause

New workstation does not have ODBC connection to run crystal reports.

Resolution

To create an ODBC connection, follow the steps below:

  1. Click on the Windows icon in taskbar and type ODBC in the search box.

  2. From the results, click on ODBC Data Sources(32-bit) to open ODBC Data Source Administrator (32-bit) window.

  3. Select User DSN tab and click on Add.

  4. In the popup window, select SQL Server at the end and click Finish

  5. In the Name text field, type a name for this connection.

  6. Description field is optional and can be left blank.

  7. In the Server text field, type the server name.

    • Please contact your IT department to obtain the database server name. 

  8. Click Next >

  9. Select the following check boxes and click Next

    • Windows NT authentication using the network Login ID

    • Connect to SQL Server to obtain default settings for the additional configuration options

  10. Select the first check box, choose munprod or mu_live from the dropdown and click Next >

  11. Click Finish.

  12. In the popup window Click on Test Data Source button in the bottom.

  13.  Click Ok.

A new connection will be added to the list in User Data Sources section. 

Additional Information

At step-8 if you receive an error "Cannot generate SSPI context", go back to step-4 and select ODBC Driver 11 for SQL Server

For other errors, please contact Enterprise ERP Reporting Services Support to troubleshoot authentication issue on database server.