TCM Error Method getDocumentCount Unable to search

Description of Issue

CM error is prompting when we pull up records in Enterprise ERP with attachments

Method 'getDocumentCount' throws: tyler.empire.search.SearchException: Unable to search

Context
  • EERP

  • Munis

  • Tyler Content Manager

  • TCM

Cause

If the error is received in just one or a few Enterprise ERP programs, the issue could be related to misconfigured mappings. The Enterprise ERP Software Support team for the specific module(s) should troubleshoot

If the issue is occurring in all programs, SearchDB or OpenSearch service could be stopped or unresponsive

Resolution

SaaS Hosted

  • If error is only in specific modules, please contact the applicable Enterprise ERP Software Support team

  • If error is in all modules, please contact Tyler Systems Management SaaS

Self-Hosted/On-Premise Hosted

  • If error is only in specific modules, please contact the applicable Enterprise ERP Software Support team

  • If error is in all modules, please see below

  1. On the TCM server, launch Services

  2. Look for and restart the Apache Tomcat service for effected environment

  3. Look for and restart SearchDB or OpenSearch service for effected environment

  4. Wait for a few minutes for these services to fully come back up and then test

Additional Information