Unable to print or reprint bill for account when using annual billing

Description of Issue

While trying to print or reprint a bill in UBCIS, user is getting an error No Bills Match Defined Criteria In Run XX And Commit XXXXXX

Context
  • UBCIS

  • Bill Print

  • Annual Billing

Cause

Bills will not generate in the Bill Print step if Annual Billing Status in UB Customers shows as Paid

Resolution

This is the expected functionality in Enterprise ERP for accounts that have paid their Annual Billing amount in full and have been marked as PAID for their Annual Billing Status in UB Customers. If a bill needs to be printed for an account that is paid the Annual Billing Status for that customer will need to be changed. This can be done using the steps below. If account was marked for annual billing in error the recommended change would be to set the status to Not Eligible.

  1. Navigate to UB Customers (Property Revenues>Utility Billing>Master Programs>Utility Billing Customers)

  2. Click Search and find the Account needing a generated bill

  3. Click Update

  4. Click the dropdown for Annual billing status

    1. Select Eligible if Annual billing is used

    2. Select Not Eligible if Annual Billing is not used

  5. Click Accept, followed by Close to close the current tab

  6. Navigate to Bill Run Process (Property Revenues>Utility Billing>Bill Processing>Bill Run Process)

  7. Click Search and find the relevant Bill Run 

  8. Click Change from the toolbar

  9. Select Bill Print

  10. Click Define and enter in the define as you normally would

  11. Under Reprint Accounts, enter the Account Number(s) in the Start reprint at account box and the Stop reprint at account box by clicking on the respective boxes

  12. Click Accept

  13. Click Generate

  14. Click Print Bills and resume your normal printing process to produce the Bill(s)

Additional Information