Time and Attendance sending duplicate emails to users

Description of Issue

Users are receiving duplicate emails from Time and Attendance.

On the Communication page, there is a Current Message Queue Size: # on top of the page. 

There is an error in the application log:

Error Sending email to: johnnor132gmail.com,johnnor132gmail.com,

com.sun.mail.smtp.SMTPAddressFailedException: 501 Invalid RCPT TO address provided

Context
  • Time and Attendance
  • TA
  • ExecuTime
  • SMTP
  • Communication Tab
Cause

There is an email address that is not formatted correctly on an end users email address field in Master File Management is causing duplicate emails to send to users. 

When there is an email queue, behaviors like sending duplicate emails or not sending emails can occur from this. 

Resolution

With the identified email address that's not formatted correctly, this will need to be corrected in the application

  1. Login to the application
  2. Navigate to System Admin > Master File Management
  3. Search for the target user
  4. Select the Pencil button to edit the target user's profile
  5. Select the Contact Info tab
  6. Modify the email address to include the '@' or to another correctly formatted email address
  7. Select Save for Current Pay Period
  8. Restart the Time and Service to clear the email queue on the Communication tab - How to restart the ExecuTime Service - OnPrem
Additional Information