Crystal Reports create ODBC connection in AWS



Description of Issue

User needs ODBC connection to run Crystal Reports against EERP database hosted in AWS



Context
  • Crystal reports

  • ODBC

  • Enterprise ERP database

  • Enterprise ERP any version

  • SaaS clients



Cause

User needs ODBC connection created to use Crystal reports



Resolution

To create an ODBC connection, follow the steps below:

  1. Click on the Windows icon in taskbar and type ODBC in the search box.

  2. From the results, click on ODBC Data Sources(64-bit) to open ODBC Data Source Administrator (64-bit) window.

  3. Select User DSN tab and click on Add.

  4. In the popup window, select ODBC Driver 17 for SQL  Server at the end and click Finish

    • If that is not an option please download it from the Microsoft

  5. In the Name text field, type a name for this connection.

  6. Description field is optional and can be left blank.

  7. In the Server text field, type the server name.

    • Note: If Server name couldn't be found in site report, please reach out to EERP TSM SaaS support team.

  8. Click Next >

  9. Select the following check boxes and click Next

    • With SQL Server authentication using a login ID and password entered by the user

    • Connect to SQL Server to obtain default settings for the additional configuration options 

  10. Select the first check box to choose your production database name from the dropdown 

    • Database name is usually munXXXXprod where XXXX is the first 4 digits of reporting account.

  11. Click Next >.

  12. Click Finish.

  13. In the popup window Click on Test Data Source button in the bottom.

  14.  Click Ok.

A new connection will be added to the list in User Data Sources section. 



Additional Information

In Step-10, if production database is not listed in dropdown, please reach out to Tyler Reporting Services Support as the default database needs to be changed for reporting account on SQL Server.

User must have a valid Reporting account (ie. 1234janedoe) prior to the connection.

All non Cyral connections will need to connect to the F5 vpn before connection.

Some additional troubleshooting information:

  • For AWS hosted clients: You MUST be connecting from behind a whitelisted IP address AND have the F5 SSL VPN Client connected

  • For Case Sensitive DBs the username case MUST match how it is entered in SQL 

  • You can see login failure reasons bu looking at the SQL logs in SSMS, expand Management > SQL Server Logs 

    • It will tell you if the account cannot be found or if the password is wrong