User seeing fewer account record results than another user- GL data access



Description of Issue
  • When searching for the same org, fund, or other segment, one user gets more account results than another user.

  • After granting a user access to a fund, user searches Account Central and still can not see all org, object, project for this fund after re-opening the program.

  • Permission to allow user to see all orgs, objects, projects of a fund

  • User not seeing all accounts has Limited GL data access with multiple segments on same record.



Context
  • Account Central

  • Account Inquiry

  • YTD Budget Report

  • User Attributes



Cause

GL data access had ranges for multiple segments on the same record, requiring multiple conditions to be met at the same time.



Resolution
  • If a user should have access to all accounts within a range for a certain segment, like fund, create a separate GL data access record in User Attributes that is not combined with any other segments that would further restrict access.

  • Review Applicable Programs to make sure programs needed are selected.

  • Any adjustments to roles apply to all users in the role.

System Administration> Security> User Attributes

  1. Search for user and Accept.

  2. Click Data Access tab.

  3. Scroll down and select General Ledger in the Module column.

  4. Below, click View Detail

  5. Select role and click Edit Role.

  6. Click on Data Access Limited folder and scroll records.

  7. If multiple segments on same record, if appropriate, use lower Delete to remove segment line and select Add to create a separate record for the segment.

  8. Click Select Programs and select programs needed.

  9. Accept

  10. Have user re-open their program before testing search.





Additional Information