General Billing Assess Late Fees not selecting Invoice



Description of Issue
  • GB Assess Late Fees is not selecting an unpaid bill and the following message is received: No records were found that satisfy the selection criteria.

  • The Assess Late Fees program is not selecting some of the Invoices that it should be. 

  • Invoices that match the Define entered into the Assess Late Fees program are not being selected. 



Context
  • General Billing

  • Assess Late Fees (gblatfee)

  • Customers (arcstmnt)



Cause
  • The Customer's gbcusdat record may be missing. This stores the Assess late fees indicator located in the General Information portion of the General Billing tab in the Customers program.

  • Invoice is not delinquent.

  • Invoice is fully Paid.

  • The Assess Late Fees Skip invoices that have this fee is selected and the fee has already been applied to the bill.

  • Assess Late Fees Define screen ranges are too limited to select the invoice.



Resolution
  • Verify that the Customer record has the Assess late fees checkbox enabled so that invoices associated with the Customer allow fees to be assessed.

    • Navigate to the Customers program via the following path: General Revenues > General Billing > Setup > Customers (Note: This path must be utilized, otherwise, the GB Customer data is not available.)

    • Click Search.

    • Enter the Customer Number associated with the Invoice that is not selecting. 

    • Click Accept.

    • Click Update.

    • Click the General Billing tab.

    • Under the General Information heading:

      1. If the Assess late fees box is checked:

        1. Click the Assess late fees box to uncheck it.

        2. Click Accept to finalize that update.

        3. Click Update again.

        4. Click the Assess late fees box so that it is now checked. 

        5. Click Accept to finalize the update. 

        6. This will trigger the gbcusdat database record to regenerate, which has been known to cause the Assess Late Fees program to not select invoices.

      2. If the Assess late fees box is unchecked: 

        1. Click the Assess late fees box so that it is checked. 

        2. Click Accept to finalize the update. 

        3. This will now allow the Customer to be assessed for late fees. 

    • Close and re-open the Assess Late Fees program and attempt to select the Invoice(s) again. 

  • Verify the invoice is unpaid and delinquent. 

  • If the Assess Late Fees program still does not select the invoice, try widening the define ranges, such as Invoice year range. 1900 to 9999, Invoice range, and Customer range.



Additional Information

Additional resources for working in the GB Assess Late Fees program can be found here: Master Article - General Billing Assess Late Fees