Users have No Access or Inquiry only to payroll programs but are still able to make changes

Description of Issue

Some employees have either no access or inquiry-only access defined on payroll programs in their Roles but are still able to make edits and save the updates. 

Context
  • Munis
  • Payroll
  • User Attributes
  • Roles
Cause

One of the user's Roles had the Payroll Superuser field defined as Restricted by Location. This allows full functionality in payroll programs for the locations the user has access to. 

Resolution

To find the Role allowing Payroll Superuser Access:

  1. Go to User Attributes (System Administration>Security>User Attributes)
  2. Search for the User. Click Accept. Click Effective Permissions tab. 
  3. Scroll down and click the line for Human Resources - Payroll - Payroll Superuser. 
  4. Click the View Detail button. 
    1. This will show each role that has HR Management/Payroll access and which one gives the Payroll Superuser access. 

In this example, the Payroll Superuser access is Restricted by Location. 

To find which Locations they have access to:

  1. Go to User Attributes (System Administration>Security>User Attributes)
  2. Search for the User. Click Accept. Click Data Access tab. 
  3. Scroll down and click the line for Human Resources - Payroll - Location Maintenance Access. 
  4. Click the View Detail button.
    1. This will show the range of Locations the user has access to.Â