The user permissions for user.name require that the payment have a deposit number


Description of Issue

Unable to complete Miscellaneous payments in Cashiering due to the following error message:

The user permissions for user.name require that the payment have a deposit number.

Context
  • Cashiering
  • EERP
  • Enterprise ERP
  • Munis
  • Deposit Reference
Cause

There is one setting in Cashiering and one setting on the user role in EERP which dictate deposit reference requirements. Whether the intention is to require deposit references or not, these two settings must match or the error will generate in Cashiering.


Resolution

In Cashiering:

  1. Navigate to Administration > External Systems,
  2. Edit Enterprise ERP. 
  3. Set Map Batch Deposit Reference to False. 
    1. If requiring deposit references, set to True. 
  4. Save.

In EERP:

  1. Navigate to System Administration > Security > User Attributes.
  2. Search for any Cashier.
  3. Highlight the role typically assigned to Cashiers. 
    1. Note: you can use the Effective Permissions tab to check the setting deposit numbers required for batches. Double-click the setting to view which role dictates the permission.
  4. Click Edit Role below.
  5. Drill into Accounts Receivable folder.
  6. Update. Change Deposit numbers on payment batches to Not Required.
    1. If requiring deposit references, set to Always Required.
  7. Accept.
Additional Information
  • The Deposit Reference field must be populated for CRP journals to pull into Bank Reconciliation Manager.