Employee cannot see Time Entry in ESS



Description of Issue
  • Employee cannot see Time Entry in ESS
  • Employee cannot submit time sheets in Employee Self Service
  • Employee cannot do time card
Context
  • Munis
  • Human Capital Management (HCM)
  • Employee Self Service (ESS)
  • Time Entry
Cause
  • The ESS Account permission View Time Entry is not checked in User Administration
  • The Job Class Master field for ESS Time Entry is not set to the value Time Entry
Resolution
  1. To review the ESS Account navigate to ESS User Administration
    • Menu > Administration > User Administration
  2. Search and locate the impacted user
  3. Click Edit 
  4. Click on the hyperlink for Employee to get to employee permissions
  5. Review the option View Time Entry, click the box to check to enable
  6. Click Update to lock in your updates


  1. To review the Job Class Master navigate to the program Job Class Master in Munis
    • Menu > Human Capital Management > Payroll > Payroll Setup
  2. Click Search and locate the impacted Job Class record
  3. Review the field ESS Time Entry
  4. Click Update and assign the value Time Entry
  5. Select Accept to save your changes
Additional Information
  • Please reach out to Munis Human Resources Support with any additional questions