Blank Or Missing Delivery Definitions Following Upgrade and ReadyForms Migration - Preset does not exist for model

Description of Issue

Delivery definitions records are blank

When clicking the ReadyForms Delivery Definitions button in Print Invoices or in Print Statements, no records are found

Preset does not exist for model

Context
  • ReadyForms

  • Delivery Definitions

Cause
  • Delivery definition preset name may be blank in the database (may be specific to migrated data from Munis version 11.3)

  • Undetermined (migrated data from Munis versions 2019+)

Resolution

System Administration > Printer / Device Administration > ReadyForms > Delivery Definitions

  1. Attempt to Delete the blank records directly from the Delivery Definitions program. If the Preset does not exist for model message is encountered, or if the record(s) can otherwise not be deleted:

    1. Create a case with EERP Forms Support to attempt importing the delivery definitions a second time

    2. if a second data import does not correct the records and/or the records can still not be deleted from the Delivery Definitions program, create a case with EERP TSM Support to query for blank presets

  2. Once the delivery definitions have been deleted (the ReadyForms templates will still be intact), see: Add a ReadyForms Delivery Definition

Additional Information

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