SSRS email subscriptions unable to modify recipient email address

Description of Issue

When configuring SSRS email subscription, the to field is grayed out preventing modification.

Context
  • SSRS Reports

  • Tyler Reporting Services

  • EERP all versions

  • SaaS, OnPrem Clients

  • Subscriptions

Cause

User does not have enough permissions to change the recipient email address in subscription.

Resolution

By default, a user with Browser role can only subscribe to reports and send it to themselves. To enforce this constraint, SSRS doesn't allow modifying the To field when configuring an email subscription. 

There are two resolutions to this issue:

  1. Grant user Content Manager role in SSRS folder permissions.

  2. Modify the configuration file on ReportServer to override this constraint.

    • Since this is a configuration change, please reach out to EERP Reporting Services Support team or create a case through online portal.

Additional Information