Vendor number greyed out in Employee Deduction

Description of Issue

Unable to update vendor number in Employee Deduction.

Context
  • Enterprise EERP
  • Employee Deductions
  • Deduction and Benefit Master
Cause

 Check Type in Deduction and Benefit Master is set to No Check.

Resolution
  1. Go to Deduction and Benefit Master (Payroll>Payroll Setup>Deduction and Benefit Master).
  2. Search for the Deduction code(s).
  3. Click Accept.
  4. Note the Check Type field.
  5. If the Check Type is set to N-No Check:
    1. No amount is processed in Vendor Processing
    2. No check or advice is printed
Additional Information

How the Deduction Check Types in Payroll impact payroll Vendor Processing

This can also happen if the user does not have permission to view/maintain AP vendors in their Role.