Report PDF or Display do not open due to Browser Pop up Blocker


Description of Issue

Select the PDF or Display option to output a report and nothing happens

When a successful define is entered and records are selected, the PDF and Display output buttons spin but produce no report or document. 

Context
  • Any Enterprise ERP/Munis Report
  • Chrome
Cause

This issue can show up if a site has a web browser Pop-up blocker enabled and the PDF's is trying to display through a PDF browser extension rather than the actual program. In web based applications, the outputs of the PDF and Display button are considered pop-ups and can be blocked by the browser's pop-up blocker. 

Resolution

Depending on which browser a site is using they might need to work with their local IT to disable the pop-up blocker or allow Munis functionality for this to no longer happen.

To turn off popup blocker for Enterprise ERP website in Chrome:

  1. On your computer, open Chrome
  2. At the top right, click the three vertical ellipses and select Settings
  3. Click Security and Privacy
  4. Click Site settings
  5. Scroll down and click Pop-ups and redirects
  6. At the top, turn the setting to Allowed or Blocked
    1. Blocked will continue blocking output. 
    2. Allowed will allow the website to open another tab to display the requested report output
Additional Information

This setting may also affect clicking hyperlinks that redirect to other pages within Enterprise ERP