NSF Button Does Not Open NSF Options and Displays NSF process complete Message

Description of Issue

When reversing a non-reversed and posted payment with the tender type of Bank, Check, or EFT and selecting NSF from the Tenders screen, the NSF options do not open and a message appears that says NSF process complete but the payment is not reversed and the fee is not added. 

Context
  • NSF Fees 
  • Payment Reversals (arrefrev)
Cause

The NSF options in the Accounts Receivable Settings for the category of the receipt being reversed do not have an NSF special condition. This is the only required field to activate this functionality. 

Resolution

Please follow the steps outlined here to add an NSF special condition to the Accounts Receivable Settings for the category of receipt being reversed: Setup NSF Fee For Payment Reversals

Additional Information
  • The special condition code is the only require field to activate this functionality. All other fields in the settings are optional. 
  • For a full explanation of the NSF functionality, please see the following article: 2019.1 NSF Functionality
  • To troubleshoot an NSF button that is grayed out, please see the following resource: NSF button grayed out
  • If additional assistance is required, please contact the appropriate support team.Â