NSF button grayed out





Description of Issue

Unable to reverse a payment and add an NSF fee at the same time because the NSF button is grayed out. 



Context
  • Munis

  • General Billing 

  • Property Tax Billing 

  • Community Development 

  • Payment Reversals (arrefrev)

  • NSF



Cause
  • NSF charge code and options not setup in AR settings.

  • The payment method is not a Check, Bank, or EFT tender type.

  • The payment has already been reversed.

  • The payment is not posted.



Resolution
  1. Full instructions for adding an NSF fee while reversing a payment can be found here: 2019.1 NSF Functionality

  2. If the NSF button is greyed out, please verify that the tender type of the receipt being reversed is Check, Bank, or EFT. 

  3. If the tender type is Check, Bank, or EFT, please verify that the receipt's Batch Status found in the Status section on the right is 40 - Completed  and the Reversal Status is Not Reversed. 

    1. If the Reversal Status of the receipt is Not Reversed and the Batch Status of the receipt is 10 - In Proof Initial, then the payment's batch needs to be released from Payment Entry and posted through Payments Journal. Follow steps 10-12 of the following article to release the batch: Enter single payments in Payment Entry

    2. If the Reversal Status of the receipt is Not Reversed and the Batch Status of the receipt is 30 - Approved, then the payment's batch needs to be posted through Payments Journal. Follow the steps in the following article to post the batch: How to post a payment batch in Payments Journal

    3. If the Reversal Status of the receipt is Reversed and the Batch Status of the receipt is 10 - In Proof Initial, then the reversal has already been created and the NSF fee must be added on through the appropriate program. 

  4. If the NSF button is still grayed out, please confirm that the NSF settings have been configured by following the guide outlined here: Setup NSF Fee For Payment Reversals



Additional Information
  • To add a fee to a tax bill where the tender type was not Check, Bank, or EFT or where the payment was reversed prior to using the NSF functionality, please follow the steps outlined here: Add a Fee to a Single Tax Bill

  • If additional assistance is required, please contact the appropriate support team.Â