Setup NSF Fee For Payment Reversals

Description of Issue

The NSF button is grayed out when reversing a payment or the functionality is not behaving as described here: 2019.1 NSF Functionality

Context
  • NSF Fees 
  • Payment Reversals (arrefrev)
Cause

The NSF setup is not complete. At minimum a special condition code is required to activate this functionality for an Accounts Receivable category. All other fields in the settings are optional. 

Resolution
  1. Navigate to the Accounts Receivable Settings program either by searching or using the following path: General Revenues > Accounts Receivable > Setup > Accounts Receivable Settings
  2. Click the Cat Specific button in the top ribbon. 
  3. Use the arrows at the bottom of the screen to navigate to the AR Category that coincides with payment type that you are trying to reverse. 
  4. Click on the Reversals tab. 
  5. Click Update. 
  6. Enter the desired NSF charge code into the Charge code field. (Note: Full field descriptions are available at any time by clicking the question mark icon in the upper right corner and then selecting Help.)
    1. If an NSF charge code needs to be added or setup for the first time, please follow the steps outlined here: Add a Charge Code. 
  7. Choose the NSF special condition.
  8. Enter the Maximum active NSFs.
  9. Choose the Cash only special condition.
    1. If a special condition code needs to be added or setup for the first time, please follow the steps outlined here: Create Special Condition Code
  10. Enter the Default NSF duration.  
  11. Click Accept
Additional Information
  • The special condition code is the only require field to activate this functionality for an Accounts Receivable category. All other fields in the settings are optional. 
  • For full troubleshooting steps regarding a grayed out NSF button, please see the following article: NSF button grayed out
  • If additional assistance is required, please contact the appropriate support team.Â