Setup NSF Fee For Payment Reversals
Description of Issue
The NSF button is grayed out when reversing a payment or the functionality is not behaving as described here: 2019.1 NSF Functionality
Context
- NSF FeesÂ
- Payment Reversals (arrefrev)
Cause
The NSF setup is not complete. At minimum a special condition code is required to activate this functionality for an Accounts Receivable category. All other fields in the settings are optional.Â
Resolution
- Navigate to the Accounts Receivable Settings program either by searching or using the following path: General Revenues > Accounts Receivable > Setup > Accounts Receivable Settings
- Click the Cat Specific button in the top ribbon.Â
- Use the arrows at the bottom of the screen to navigate to the AR Category that coincides with payment type that you are trying to reverse.Â
- Click on the Reversals tab.Â
- Click Update.Â
- Enter the desired NSF charge code into the Charge code field. (Note: Full field descriptions are available at any time by clicking the question mark icon in the upper right corner and then selecting Help.)
- If an NSF charge code needs to be added or setup for the first time, please follow the steps outlined here: Add a Charge Code.Â
- Choose the NSF special condition.
- Enter the Maximum active NSFs.
- Choose the Cash only special condition.
- If a special condition code needs to be added or setup for the first time, please follow the steps outlined here: Create Special Condition Code
- Enter the Default NSF duration. Â
- Click Accept
Additional Information
- The special condition code is the only require field to activate this functionality for an Accounts Receivable category. All other fields in the settings are optional.Â
- For full troubleshooting steps regarding a grayed out NSF button, please see the following article: NSF button grayed out
- If additional assistance is required, please contact the appropriate support team.Â