Unable to see new Step in Employee Job Salary after updating Salary Table



Description of Issue

After updating a Salary Table to include additional steps, when updating an employee's Job/Salary record, the new steps do not appear when selecting the ellipses button next to the Step field.



Context
  • Payroll

  • Position Control

  • Job Class Master

  • Employee Job/Salary



Cause

The Max Step field in Position Control or Job Class Master was not adjusted to account for the increase in steps in the new Salary Table.



Resolution

If the Position Control record has a defined Max Grade/Step:

  1. Navigate to Position Control (Human Resources>Position Control and Budgeting>Position Control)

  2. Click Search and find the Position record

  3. Navigate to the Salary Data tab

  4. Select Update and adjust the Max Step field to mirror the highest step of the new Salary Table

  5. Select Accept

If the Job Class Master record has a defined Max Grade/Step:

  1. Navigate to Job Class Master (Payroll>Payroll Setup>Job Class Master)

  2. Click Search and find the Job Class record

  3. Navigate to the Salary Data tab

  4. Select Update and adjust the Max Step field to mirror the highest step of the new Salary Table

  5. Select Accept

After adjusting these fields, the newly adjusted steps should appear when selecting



Additional Information

If multiple Positions need to be adjusted, you can use the Position Control Import:

Position Control Import