HUB shows Tyler Hub Business MenuResolver error



Description of Issue

HUB administration error logs error shows ERROR Tyler.Hub.Business.MenuResolver user: XXXXXXXXX :: MoveNext :: An exception occurred loading the menu for provider: 3c21e2e1-730f-4460-80ff-c29f62730f35, card: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXX



Context
  • Tyler Hub

  • Munis



Cause

User email address may have been updated in HUB and/or Munis User Attributes and requires a re-sync.



Resolution
  1. Log into HUB and click the the cog wheel to access Administration:

    1. System settings > Logs and Diagnostics > System Logs

    2. Logging Level: Error

    3. Available logs: click on most recent date to download the HUB error log.

  2. Open log with Notepad (or Notepad++) and press CTRL+F:

    1. Search for 3c21e2e1-730f-4460-80ff-c29f62730f35

      1. If you see this record in your results this means the menu is failing to resolve for the Munis user.

    2. Click Back to return the HUB page.

  3. On the Tyler Menu card click the ellipses (three vertical dots) and click Refresh.



Additional Information

Please create a case with TSM Support for further assistance in the Support Portal.

Please review the Master Article - Tyler Hub for all related topics.