Munis CSS UB Bill Search is Slow



Description of Issue

When looking for utility bills in CSS, it takes a long time to get the list of bills after clicking Manage Bills.



Context
  • Munis Citizen Self Service

  • All versions



Cause

Slow loading of the Manage Bills page is usually a result of too many bills being retrieved. 



Resolution
  1. Log in to CSS as an administrator and navigate to Administration > Citizen Administration > Utility Billing Administration

  2. Near the bottom of the screen, review the Search Field Setup options:

    1. The biggest contributor to performance is the Bill year field. If that field is not set to be Required, then the Manage Bills page will load a little slower after every bill run as it retrieves more and more bills

    2. Also review the Bill year search default settings to control what citizens will see for a default bill year. This may need to be reviewed periodically, depending on how it's configured

  3. Test bill search to verify the performance improvement



Additional Information

The Past Bills to Display field doesn't impact performance at all. It merely shortens the list after all of the bills have been retrieved.