User with multiple roles cannot access General Ledger accounts



Description of Issue
  • User has multiple roles that each have different data access set up 

  • Users can only access the accounts and segments that all roles share data access for

  • General Ledger Settings has Inclusive selected for Account restriction for users with multiple roles option.



Context
  • User Attributes

  • General Ledger Settings



Cause

Site is set up to have Exclusive data access for users with multiple roles.



Resolution

User will only be able to access segments that are provided data access by ALL of their roles

Munis > System Administration > Security > User Attributes

  1. Search for the user using their name or User ID

  2. In the Roles tab, make note of how many roles a user has

  3. Select the Data Access tab

  4. Scroll down to the General Ledger data access labeled Account/segment group access

  5. Click the View Detail button to review the data access provided by each role



Additional Information

In the General Ledger Settings there is a permission labeled Account restrictions for users with multiple roles, which can be set to either Inclusive or Exclusive.

If the setting is Inclusive, then a user will be able to access any accounts that at least one of their roles provides access to, regardless if the other roles do not provide data access for those same segments or accounts.

If the setting is Exclusive, then a user would need to have the same data access granted by all of their roles in order to be able to access the account or segment.

NOTE: This does not affect users that only have only one role in their User Attributes.