Register Timeclock error - Could not login to the Web Service



Description of Issue

When registering a TouchTime clock, \ramdisk\errors.txt records ...

[12:31:5:358]Calling ETWebService.callSoapMethod registerTimeClock
[12:31:5:650]#### Exception Server Error ####
[12:31:5:660]Could not login to the Web Service.
net.executime.exception.WebServiceException: Could not login to the Web Service.



Context
  • TouchTime Clocks

  • Registering

  • ExecuTime



Cause

The Timeclock user password in ET is changed, it also has to be updated in the UI Environment Flags > Timeclock Configuration tab.  

The password is changed before you attempted to register a clock, that could definitely cause the clock to return that 'Could not login to the web service' error.



Resolution

Change the value in Timeclock Configuration first, run a configuration job so that the clocks get the new password.  Change the password on the user in ET so that the clock is able to login to the application correctly

  1. Change the password in the timeclock user profile in Time & Attendance 

    1. System Admin > Master File Management > Employees

    2. Edit employee name **DO NOT MODIFY**, Time Clocks ()

    3. Enter Password 

      1. Don't have a record of this password? Please contact Time & Attendance Support or log a case via the Online Support Client Portal and reference this article

    4. Enter Password again to Confirm

    5. Hit Save For Current Pay Period

  2. Change the password on UI Environment Flags > Timeclock Configuration

  3. Save

  4. Run Timeclock Configuring job;

    1. System Admin > Scheduled System Jobs > Timeclock Configuring to send the new password to the devices. 



Additional Information

The flashdisk\device.cfg file on the clock can be edited to set the password to the correct value, that should resolve the error on the clock