Cannot login to Time and Attendance Non-Prod after refresh with TID Enabled

Description of Issue

Users receiving error message when attempting to login to Non-Prod instance

  • Username or password is incorrect

  • The user was not found in Time & Attendance. Please check with the administrator to be added to the application

Context
  • Time & Attendance

  • ExecuTime

  • TA

  • ET

  • Tyler Identity

  • TID

  • Refresh

  • Non-Prod instance

Cause

This is occurring because Prod hasn’t been enabled with TID and Non-Prod has. One of the primary requirements for TID is to have the LoginID set to an email formatted value. The Prod instance has Employee numbers in the LogiID field of TA. The refresh process begins with a database restore over the target Non-Prod instance. This means the employee table will contain the values from Prod (e.g., Employee number format), which is not compatible with TID.

Resolution
  1. Use the special Admin access URL to access the target instance (e.g., .../ExecuTime/Login_admin.action)

  2. Access System Configuration > Admin

  3. Scroll to the bottom and select Employee Build Mapping Table

  4. Under the Time & Attendance Field Name column, look for the row named Login ID

  5. Enter primaryEmail under the Payroll System Field name on the Login ID row replacing whatever value may exist there already, if any.

  6. Ensure that the drop down box in the Update this field column is set to Yes for the Login ID row.

  7. Hit Save

  8. Navigate to the System Configuration > Tyler Integration tab

  9. Click the Run full data import button for the Employee integration job

  10. Click Only run job

  11. Confirm that the Login ID field for employees are now populated with email addresses.

Additional Information

Note: Users email addresses must be entered for the users in the payroll system for the Login ID field in Time and Attendance to be populated with the email address